summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authormalosek <malosek@fastmq.com>2009-09-07 17:06:47 +0200
committermalosek <malosek@fastmq.com>2009-09-07 17:06:47 +0200
commitb71c3005e68d02f800ff09bcacece79d167bff75 (patch)
treef8a82fbb1cdc5f20e21da9809ea20c93f16bca56 /src/Makefile.am
parentf895426c1885729f4a4a20b1eb543a92915aed85 (diff)
include directory split into c and cpp dirs, added --with-c and --with-cpp configure options
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am15
1 files changed, 12 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 88a6f4b..da442f4 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,8 +1,17 @@
lib_LTLIBRARIES = libzmq.la
-pkginclude_HEADERS = \
- ../include/zmq.h \
- ../include/zmq.hpp
+
+if BUILD_CPP
+include_HEADERS = ../cpp/zmq.hpp ../c/zmq.h
+endif
+
+if BUILD_C
+if BUILD_CPP
+
+else
+include_HEADERS = ../c/zmq.h
+endif
+endif
libzmq_la_SOURCES = \
app_thread.hpp \