summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorMikko Koppanen <mkoppanen@php.net>2011-01-20 22:13:01 +0100
committerMartin Sustrik <sustrik@250bpm.com>2011-01-20 22:13:01 +0100
commit8e61a11b398c95d829f24c388737eb122405c97b (patch)
treeb295adfc45edee7b1d52f2737ac64467250a5cec /tests/Makefile.am
parent8561a55d2ca3f99ef7d122cf621b2379924152a5 (diff)
Do not execute ipc tests under MinGW
Signed-off-by: Mikko Koppanen <mkoppanen@php.net>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index bdc55d2..30ca62c 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -2,26 +2,26 @@ INCLUDES = -I$(top_builddir)/include
LDADD = $(top_builddir)/src/libzmq.la
noinst_PROGRAMS = test_pair_inproc \
- test_pair_ipc \
test_pair_tcp \
test_reqrep_inproc \
- test_reqrep_ipc \
test_reqrep_tcp
if !ON_MINGW
-noinst_PROGRAMS += test_shutdown_stress
+noinst_PROGRAMS += test_shutdown_stress \
+ test_pair_ipc \
+ test_reqrep_ipc
endif
test_pair_inproc_SOURCES = test_pair_inproc.cpp testutil.hpp
-test_pair_ipc_SOURCES = test_pair_ipc.cpp testutil.hpp
test_pair_tcp_SOURCES = test_pair_tcp.cpp testutil.hpp
test_reqrep_inproc_SOURCES = test_reqrep_inproc.cpp testutil.hpp
-test_reqrep_ipc_SOURCES = test_reqrep_ipc.cpp testutil.hpp
test_reqrep_tcp_SOURCES = test_reqrep_tcp.cpp testutil.hpp
if !ON_MINGW
test_shutdown_stress_SOURCES = test_shutdown_stress.cpp
+test_pair_ipc_SOURCES = test_pair_ipc.cpp testutil.hpp
+test_reqrep_ipc_SOURCES = test_reqrep_ipc.cpp testutil.hpp
endif
TESTS = $(noinst_PROGRAMS)