summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorMartin Sustrik <sustrik@250bpm.com>2011-06-23 07:57:47 +0200
committerMartin Sustrik <sustrik@250bpm.com>2011-06-23 07:57:47 +0200
commitd1373792f7888f312cd7286fdf524a0bfe124846 (patch)
tree046c7a5473b43b50be02ef34705e2a45e753c51c /tests/Makefile.am
parent12532c7940f23fcb3cd46208c141d47647e76231 (diff)
Outstanding requests dropped when requester dies (issue 190)
So far the requests in req/rep pattern were delivered to and processed by worker even though the original requester was dead. Thus, the worker processing replies with noone to deliver results to. This optimisation drops requests in two situations: 1. Queued inbound requests in XREP socket when peer disconnects. 2. Queued outbound requests in XREQ when socket is closed. Signed-off-by: Martin Sustrik <sustrik@250bpm.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am7
1 files changed, 3 insertions, 4 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 9238850..8ec3b0c 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -6,7 +6,8 @@ noinst_PROGRAMS = test_pair_inproc \
test_reqrep_inproc \
test_reqrep_tcp \
test_hwm \
- test_reqrep_device
+ test_reqrep_device \
+ test_reqrep_drop
if !ON_MINGW
noinst_PROGRAMS += test_shutdown_stress \
@@ -17,13 +18,11 @@ endif
test_pair_inproc_SOURCES = test_pair_inproc.cpp testutil.hpp
test_pair_tcp_SOURCES = test_pair_tcp.cpp testutil.hpp
-
test_reqrep_inproc_SOURCES = test_reqrep_inproc.cpp testutil.hpp
test_reqrep_tcp_SOURCES = test_reqrep_tcp.cpp testutil.hpp
-
test_hwm_SOURCES = test_hwm.cpp
-
test_reqrep_device_SOURCES = test_reqrep_device.cpp
+test_reqrep_drop_SOURCES = test_reqrep_drop.cpp
if !ON_MINGW
test_shutdown_stress_SOURCES = test_shutdown_stress.cpp