summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 19 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index f518509..8483dae 100644
--- a/configure.in
+++ b/configure.in
@@ -388,11 +388,21 @@ if test "x$with_pgm_ext" != "xno"; then
;;
esac
+ AC_CHECK_HEADERS(openssl/md5.h, [] ,
+ [AC_MSG_ERROR([To run configure with --with-pgm option, openssl/md5.h has to be usable.])])
+
+ AC_CHECK_LIB(ssl, MD5_Init, , [AC_MSG_ERROR([Could not link with libuuid, install develop version.])])
+
AC_CHECK_PROG(have_tar, tar, yes, no)
if test "x$have_tar" != "xyes"; then
AC_MSG_ERROR([Could not find tar.])
fi
+ AC_CHECK_PROG(have_patch, patch, yes, no)
+ if test "x$have_patch" != "xyes"; then
+ AC_MSG_ERROR([Could not find patch.])
+ fi
+
AC_CHECK_PROG(have_bunzip2, bunzip2, yes, no)
if test "x$have_bunzip2" != "xyes"; then
AC_MSG_ERROR([Could not find bunzip2.])
@@ -416,7 +426,15 @@ if test "x$with_pgm_ext" != "xno"; then
if tar -xjf foreign/openpgm/${pgm_basename}.tar.bz2 -C foreign/openpgm/; then
AC_MSG_RESULT([yes])
else
- AC_MSG_ERROR([Could not unpack foreign/openpgm/${pgm_basename}.tar.bz2 file])
+ AC_MSG_ERROR([Could not unpack foreign/openpgm/${pgm_basename}.tar.bz2 file.])
+ fi
+
+ AC_MSG_CHECKING([Patching ${pgm_basename}])
+
+ if patch --silent -p0 < foreign/openpgm/lost_data_tsi.patch; then
+ AC_MSG_RESULT([yes])
+ else
+ AC_MSG_ERROR([Could not apply foreign/openpgm/lost_data_tsi.patch file.])
fi
# Generate galois_tables.c