summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 7fbc2cf..da7f0b1 100644
--- a/configure.in
+++ b/configure.in
@@ -58,8 +58,10 @@ AC_PROG_AWK
AC_CHECK_LIB([pthread], [pthread_create])
# If using GNU C++, libstdc++ must be available.
if test "x$GXX" = "xyes"; then
+ # libstdc++ depends on libm on some platforms
+ AC_CHECK_LIB([m], [main])
AC_CHECK_LIB([stdc++], [main], ,
- [AC_MSG_ERROR([cannot link with -lstdc++])], [-lm])
+ [AC_MSG_ERROR([cannot link with -lstdc++])])
fi
# Extra CXXFLAGS are appended at the end of CXXFLAGS for libzmq.