summaryrefslogtreecommitdiff
path: root/devices/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'devices/Makefile.am')
-rw-r--r--devices/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/devices/Makefile.am b/devices/Makefile.am
index ab18976..4f20456 100644
--- a/devices/Makefile.am
+++ b/devices/Makefile.am
@@ -6,5 +6,9 @@ if BUILD_STREAMER
STREAMER_DIR = zmq_streamer
endif
-SUBDIRS = $(FORWARDER_DIR) $(STREAMER_DIR)
-DIST_SUBDIRS = zmq_forwarder zmq_streamer
+if BUILD_QUEUE
+QUEUE_DIR = zmq_queue
+endif
+
+SUBDIRS = $(FORWARDER_DIR) $(STREAMER_DIR) $(QUEUE_DIR)
+DIST_SUBDIRS = zmq_forwarder zmq_streamer zmq_queue