summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am17
1 files changed, 13 insertions, 4 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index bad1538..0825ae8 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,10 +1,19 @@
INCLUDES = -I$(top_builddir)/include
LDADD = $(top_builddir)/src/libzmq.la
-noinst_PROGRAMS = simple test_pair test_reqrep
+noinst_PROGRAMS = test_pair_inproc \
+ test_pair_ipc \
+ test_pair_tcp \
+ test_reqrep_inproc \
+ test_reqrep_ipc \
+ test_reqrep_tcp
-simple_SOURCES = simple.cpp
-test_pair_SOURCES = test_pair.cpp testutil.hpp
-test_reqrep_SOURCES = test_reqrep.cpp testutil.hpp
+test_pair_inproc_SOURCES = test_pair_inproc.cpp testutil.hpp
+test_pair_ipc_SOURCES = test_pair_ipc.cpp testutil.hpp
+test_pair_tcp_SOURCES = test_pair_tcp.cpp testutil.hpp
+
+test_reqrep_inproc_SOURCES = test_reqrep_inproc.cpp testutil.hpp
+test_reqrep_ipc_SOURCES = test_reqrep_ipc.cpp testutil.hpp
+test_reqrep_tcp_SOURCES = test_reqrep_tcp.cpp testutil.hpp
TESTS = $(noinst_PROGRAMS)