summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index e580802..bdc55d2 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -6,8 +6,11 @@ noinst_PROGRAMS = test_pair_inproc \
test_pair_tcp \
test_reqrep_inproc \
test_reqrep_ipc \
- test_reqrep_tcp \
- test_shutdown_stress
+ test_reqrep_tcp
+
+if !ON_MINGW
+noinst_PROGRAMS += test_shutdown_stress
+endif
test_pair_inproc_SOURCES = test_pair_inproc.cpp testutil.hpp
test_pair_ipc_SOURCES = test_pair_ipc.cpp testutil.hpp
@@ -17,6 +20,8 @@ test_reqrep_inproc_SOURCES = test_reqrep_inproc.cpp testutil.hpp
test_reqrep_ipc_SOURCES = test_reqrep_ipc.cpp testutil.hpp
test_reqrep_tcp_SOURCES = test_reqrep_tcp.cpp testutil.hpp
+if !ON_MINGW
test_shutdown_stress_SOURCES = test_shutdown_stress.cpp
+endif
TESTS = $(noinst_PROGRAMS)