summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMartin Lucina <mato@kotelna.sk>2011-04-07 15:37:46 +0200
committerMartin Lucina <martin@lucina.net>2012-01-23 08:53:43 +0100
commit8eea9178e40abf16c0e469465a58fba3beaaf754 (patch)
treeda36e07db727b5c30c8e5c7745275b9d6d48131f /debian/rules
parent3e20cb1b8a2b1ca222011df37334e5f4f88dd565 (diff)
parent8e61b98c5e2943b149c825310b24e714a6127072 (diff)
Imported Debian patch 2.1.4-1debian/2.1.4-1
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules15
1 files changed, 7 insertions, 8 deletions
diff --git a/debian/rules b/debian/rules
index 6d8f530..a6187d5 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,14 +2,13 @@
#export DH_VERBOSE=1
-# Temporarily disabled due to upstream changes in OpenPGM integration.
-# DEB_HOST_ARCH := $(shell dpkg-architecture -qDEB_HOST_ARCH)
-#
-# ifneq (,$(filter $(DEB_HOST_ARCH),i386 amd64))
-# pgm_opt := --with-pgm
-# else
+DEB_HOST_ARCH := $(shell dpkg-architecture -qDEB_HOST_ARCH)
+
+ifneq (,$(filter $(DEB_HOST_ARCH),i386 amd64))
+ pgm_opt := --with-pgm
+else
pgm_opt :=
-# endif
+endif
ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
@@ -44,7 +43,7 @@ clean:
rm -f build-stamp configure-stamp
if [ -e Makefile ]; then make distclean; fi
- rm -rf foreign/openpgm/libpgm-2.0.20rc5 config.log
+ rm -rf foreign/openpgm/build-staging config.log
dh_clean