summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules15
1 files changed, 7 insertions, 8 deletions
diff --git a/debian/rules b/debian/rules
index 6d8f530..a6187d5 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,14 +2,13 @@
#export DH_VERBOSE=1
-# Temporarily disabled due to upstream changes in OpenPGM integration.
-# DEB_HOST_ARCH := $(shell dpkg-architecture -qDEB_HOST_ARCH)
-#
-# ifneq (,$(filter $(DEB_HOST_ARCH),i386 amd64))
-# pgm_opt := --with-pgm
-# else
+DEB_HOST_ARCH := $(shell dpkg-architecture -qDEB_HOST_ARCH)
+
+ifneq (,$(filter $(DEB_HOST_ARCH),i386 amd64))
+ pgm_opt := --with-pgm
+else
pgm_opt :=
-# endif
+endif
ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
@@ -44,7 +43,7 @@ clean:
rm -f build-stamp configure-stamp
if [ -e Makefile ]; then make distclean; fi
- rm -rf foreign/openpgm/libpgm-2.0.20rc5 config.log
+ rm -rf foreign/openpgm/build-staging config.log
dh_clean