summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMartin Lucina <mato@kotelna.sk>2011-05-09 11:20:08 +0200
committerMartin Lucina <martin@lucina.net>2012-01-23 08:53:47 +0100
commitf34d1599a651dd0b8feba2397f87629733988384 (patch)
tree07694c4ed96bf7b0ecadebc76d6da3f6c0125219 /debian/rules
parent8eea9178e40abf16c0e469465a58fba3beaaf754 (diff)
parentcbaa7cfa93893876e4fd8794b6ea39f4d245b6b5 (diff)
Imported Debian patch 2.1.6-1debian/2.1.6-1
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules20
1 files changed, 1 insertions, 19 deletions
diff --git a/debian/rules b/debian/rules
index a6187d5..c40e309 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,14 +2,6 @@
#export DH_VERBOSE=1
-DEB_HOST_ARCH := $(shell dpkg-architecture -qDEB_HOST_ARCH)
-
-ifneq (,$(filter $(DEB_HOST_ARCH),i386 amd64))
- pgm_opt := --with-pgm
-else
- pgm_opt :=
-endif
-
ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
MAKEFLAGS += -j$(NUMJOBS)
@@ -22,7 +14,7 @@ configure-stamp:
./configure $(CROSS) \
--prefix=/usr \
- $(pgm_opt) \
+ --with-system-pgm \
CFLAGS="$(CFLAGS)" \
LDFLAGS="-Wl,--as-needed -Wl,-z,defs" \
@@ -43,7 +35,6 @@ clean:
rm -f build-stamp configure-stamp
if [ -e Makefile ]; then make distclean; fi
- rm -rf foreign/openpgm/build-staging config.log
dh_clean
@@ -81,12 +72,3 @@ binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install configure
# vim: set filetype=make
-
-
-# build depends:
-# - python[-all]-dev
-# - ruby-dev
-# -> figure out ruby-headersdir option automatically
-# - openjdk-6-jdk (or whatever)
-# -> set JAVA_HOME automatically
-# - libglib2.0-dev