summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorMartin Lucina <mato@kotelna.sk>2010-02-11 17:49:40 +0100
committerMartin Lucina <mato@kotelna.sk>2010-02-11 17:49:40 +0100
commit30b967e2a439ce76b1141d34fa3c8ee9f87a88a8 (patch)
tree96f1664ea42e8149877a0d2fa0078ba3e04545d8 /doc/Makefile.am
parent432fbd796bb4905fb19ceee802009b17e88e9256 (diff)
Integrate version numbering into autoconf
configure.in is now the master source for the package version number, this propagates to src/platform.hpp (for zmq_version) and doc/Makefile.am (for documentation generation) automagically.
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index c57eb7c..c91c808 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -29,9 +29,11 @@ dist-hook : $(MAN_DOC) $(MAN_HTML)
SUFFIXES=.html .txt .xml .1 .3 .7
.txt.html:
- asciidoc -d manpage -b xhtml11 -f asciidoc.conf $<
+ asciidoc -d manpage -b xhtml11 -f asciidoc.conf \
+ -azmq_version=@PACKAGE_VERSION@ $<
.txt.xml:
- asciidoc -d manpage -b docbook -f asciidoc.conf $<
+ asciidoc -d manpage -b docbook -f asciidoc.conf \
+ -azmq_version=@PACKAGE_VERSION@ $<
.xml.1:
xmlto man $<
.xml.3: